How To Fix “Missing Dependency: perl(URI) >= 1.17 is needed by package subversion”

If you are a cPanel user on CentOS 5.6 64 bit and wanting to install Subversion, you might get this error after running ‘yum install subversion’

Missing Dependency: perl(URI) >= 1.17 is needed by package subversion-1.6.11-7.el5_6.4.x86_64

yum seems to unable to find needed dependency and just fails

To fix this issue there’s a workaround.


cd /tmp
wget http://sdkit.com/download/centos/5/rpms/perl-URI-1.35-3.noarch.rpm
rpm -i perl-URI-1.35-3.noarch.rpm



The dependency is now fixed. You can proceed to installing subversion by running:

yum install subversion

3 thoughts on “How To Fix “Missing Dependency: perl(URI) >= 1.17 is needed by package subversion””

Leave a Reply to How To Fix “Missing Dependency: perl(URI) >= 1.17 is needed by package subversion” | romacities notepad Cancel reply

Your email address will not be published. Required fields are marked *

You may use these HTML tags and attributes: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <s> <strike> <strong>